Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Perimeter mit Ardumower-1.0a7-Azurit

Perimeter mit Ardumower-1.0a7-Azurit 2 years 1 month ago #13204

  • Juister
  • Juister's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 2
  • Thank you received: 2
Hallo liebe Mower Gemeinde,
bis jetzt hatte ich nie ein Problem … alles konnte man Erlesen.
Aber jetzt weiß ich nicht mehr weiter.
Mein Problem ist mit dem Perimeter Empfang.
Mit der Software Ardumower-1.0a6-Azurit läuft alles
gut und der Perimeter Empfang ist Stabil .
Mit der neuen Software Ardumower-1.0a7-Azurit wo ich das PCB 1.2 in „mower.h“
eingetragen habe schwanken die Werte ( im Stillstand vom Mower ) von -1800(IN) bis 1800(out)
Hier mal ein Video:


Habe ich was vergessen in den Einstellungen? Für eine Info wäre ich sehr Dankbar.
Gruß aus Göttingen
Carsten



Meine Hardware:
PCB 1.2
2x Protector Board
Mega 2560
2x MC 33926
DS 1307
2x INA 169
BT HC-05
Sony Konion 7S2P Lithium Ion Akkupack
Perimeter Sender Board V2 mit neuer Software ver. 596
The following user(s) said Thank You: nero76

Please Log in or Create an account to join the conversation.

Perimeter mit Ardumower-1.0a7-Azurit 2 years 1 month ago #13205

  • nero76
  • nero76's Avatar
  • Offline
  • Admin
  • Admin
  • cofounder of www.ardumower.de
  • Posts: 2306
  • Thank you received: 818
Hallo,
da haben wir wohl den Mega bei unseren Tests mit Azurit 1.0a7 etwas vernachlässigt - das hole ich in den nächsten Tagen nach. Es müsste dann ja auch bei mir auftreten. Es sieht im Video so aus als wenn der ADC die Frequenz nicht mehr schafft (beim Mega geht das nur Interrupt-gesteuert und ist damit sehr sehr CPU-lastig - die ADC-Interrupts unterbrechen das aktuelle Programm für jedes ADC-Sampling und es wäre seltsam dass dies plötzlich nicht mehr zu 100% klappt). Ich teste Azurit 1.0a7 nochmal ausführlich mit dem Mega.
Gruss,
Alexander

Please Log in or Create an account to join the conversation.

PCB1.3 - die Plug&Play Robotik-Plattform für Deinen Rasenroboter mit passender Open Source Software
Last Edit: by nero76.

Perimeter mit Ardumower-1.0a7-Azurit 2 years 1 month ago #13206

  • nero76
  • nero76's Avatar
  • Offline
  • Admin
  • Admin
  • cofounder of www.ardumower.de
  • Posts: 2306
  • Thank you received: 818
Ich hatte soeben die Möglichkeit Azurit 1.0a7 mit dem Mega zu testen - Perimeter läuft einwandfrei. Ich kann den genannten Fehler nicht reproduzieren.
The following user(s) said Thank You: Juister

Please Log in or Create an account to join the conversation.

PCB1.3 - die Plug&Play Robotik-Plattform für Deinen Rasenroboter mit passender Open Source Software

Perimeter mit Ardumower-1.0a7-Azurit 2 years 1 month ago #13208

  • Juister
  • Juister's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 2
  • Thank you received: 2
Wow, das geht mal schnell mit der Fehlersuche.
Ich habe in der Zwischenzeit mal einen Arduino Due auf das PCB1.2 gesteckt und die Azurit 1.0a7 drauf Geladen. Und siehe da, Perimeter läuft Stabil und der Wert ist sogar höher an der selben Stelle.
Wenn ich den Fehler am Mega 2560 gefunden habe werde ich noch kurz Berichten.
Besten Dank

Gruß Carsten
The following user(s) said Thank You: nero76

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: runtimeterror
Time to create page: 0.361 seconds