Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: Problem to receive

Problem to receive 6 Monate 1 Woche her #16907

  • Rubberduck
  • Rubberducks Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 5
  • Dank erhalten: 0
Hi

I kindly ask for your help. I have a very low smag, below 100, despite a good(?) signal from LM386.

Could this be because of the high and narrow peek? The "coil_signal_without_capacitor" from the wiki shows that the signal (the +1 and -1) from the LM386 is more flat and longer. So it is possible to measure it. I think the signal (the narrow peek) to my Arduino MEGA is to short - the ADC has no chance to catch it.

What can I do?

Best regards
Andreas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem to receive 6 Monate 1 Woche her #16911

  • Bernard
  • Bernards Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 985
  • Dank erhalten: 186
Hi.
Certainly the narrow peek is the issue .
Not sure but if i remember ,The ADC read 4 values inside the 104 micro second signal so if the peek is no longuer than 26 micro second it's not working.
On the receiver LM286 :Check again the shunt on the capacitor and the potentiometer position( at the max ),
On the sender The sense normaly near 1 Amp and what is the scope result at 1 cm of the wire.

By.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem to receive 6 Monate 1 Woche her #16913

  • Rubberduck
  • Rubberducks Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 5
  • Dank erhalten: 0
Hi Bernard,
Thank you so much for helping me.
The potentiometer is at the max.
The sender is 8V and 1A.
First picture shows the background noise.
When the wire is 1 cm from the inductor the LM386 is saturated (at least I think it is). But there is a picture on that. Please notice the different scaling.
And there is one picture when the wire is 6 cm from.
The last two shows the difference between Slew on MC33926 is High and not connected - here the wire was 10 cm away from. The difference in SMAG is very smal (if any) beteween the two. I can not see any difference when Slew is Low.
I have also tested with another LM386 but there was no difference.

Tanks again for helping me
Andreas

EDIT: The shunt for the capacitor is in place

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von Rubberduck.

Problem to receive 6 Monate 1 Woche her #16914

  • Bernard
  • Bernards Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 985
  • Dank erhalten: 186
Hi.
It's Strange that the peek is very short at 1 or 6 cm
The coil need to be perpendicular of the wire
.What is the wire lenght? And the power resistor.You say 8V 1A ,Is it only 8 Ohm Power (50 Watts ?) reristor ?

Can you send picture of the receiver with the coil ?

Here what i have at 10 CM in the best condition :
Grey Scale is 200 micro second on x axis so the peek is near 50 micro second duration and the smag is near 1800 in this case.




You can also see the excelent tuto of Roland on Youtube concerning the perimeter signal.

Maybe check the power resistor,the wire or try other coil,If you have one.
.

Good luck.
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem to receive 6 Monate 1 Woche her #16915

  • Roland
  • Rolands Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 719
  • Dank erhalten: 244
Did you bridged the condensator on the receiver? I think yes, but not sure.
Normally you signal looks good. What is the magentude (not smag) 15cm inside the perimeter. There you normally have the higest amplitude. If you have one Ampere, then the perimeter wire should be long and have no loops nearby which could influence the signal in the coil. If you have only 10m perimeter, try 300mA signal. Maybe they changed something in the software for calculating the magnetude? I am not sure.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

"There’s a way to do it better - find it" ― Thomas A. Edison

Problem to receive 6 Monate 1 Woche her #16916

  • Rubberduck
  • Rubberducks Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 5
  • Dank erhalten: 0
Thank you both!
I will need a little bit of time to answer your questions and test your suggestions. I probably don't have the best layout on the perimeter.
I report what I found out.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem to receive 6 Monate 1 Woche her #16920

  • Rubberduck
  • Rubberducks Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 5
  • Dank erhalten: 0
Hello again,

I have rearranged the wire, now it is around 18 m long. With 3 power resistors @3,3 ohm each. The only thing changed is the layout of the wire and that I reduced it 1 m to get rid of some "loops" . The wire is near the walls in a 20 m2 room. I dropped the voltage as much as I could, to 5 Volts and 0,44 amp. The pictures is taken on the current setup, at the same time. The receiver is 15 cm from the wire. The coil that I bought should be 100mH, and I have tested with another one but the same result. I will take one to work tomorrow and measure it. The condensator on the LM386 has a shunt.

PS the tuto by Roland is excellent and I have learned a lot. But so far I have not noticed anything that could explain why I get so much lower result. Probably It's just me that missed something obvious.

Thanks again!
/Andreas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem to receive 6 Monate 6 Tage her #16924

  • Roland
  • Rolands Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 719
  • Dank erhalten: 244
You have a lot of noise on the signal. I don't know where this comes from and if this is the reason for your small magnitude. But first I would do the following: Throw out the breadboard and get 5v direct from the Due The breadboard
could be a source of error. Then tie the cable from the receiver to the due together that there is no loop. You have only three cables: 5V, Signal and GND. Lay the 5V cable direct over the receiver. Don't connect a gnd cable to the coil additionally. Put the receiver away from the USB calble of the DUE.

By the way, if you take a look as Bernards signal, which is totally overdrived, his signal pulse is as long as yours, isn't it? Please check this after you get rid of the noise.
IMPORTANT: Solder a voltage divider behind the receiver (10k/20k). The DUE can only handle 3.3V. When you overdrive the receiver it gives out more than 3.3V.
Furthermore, change your signalsender in the way, that you can measure the length of a complete signal. Maybe the frequency is not correct.
Folgende Benutzer bedankten sich: Rubberduck

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

"There’s a way to do it better - find it" ― Thomas A. Edison
Letzte Änderung: von Roland.

Problem to receive 6 Monate 6 Tage her #16926

  • Bernard
  • Bernards Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 985
  • Dank erhalten: 186
Hi.
Yes a lot of noise but:
Try with coil from marotronics.(Do not overheat them when solder or first try with screw)
Try the wire outdoor on big loop.
Try the receiver without the DUE Simply power the LM386 with a powerbank and connect the scope between gnd and signal.

Move the coil in the room to see if the noise is everywhere and see if the scope or PC or ?? can generate it.
In the past i have a lot of issue with some coil
All DC/DC converter can also do this.
www.ardumower.de/index.php/de/forum/your...ttform?start=20#9516 .


I work actualy on WIFI or LORA communicating sender:
Here some picture of 2 kind of senders .

First one is very low cost:
Only LM2596 DC/DC ,Nano,INA169 and L298N motor board (ESP01 and LED are optional)

The Receiver output :



Second one
Only LM2596 DC/DC ,Heltec ESP32 LORA oled module,INA169 and L298N motor board




And the result is exactly the same:


The Sender is powered by a 12V 5A DC power supply.
The Voltage on the motor driver is 8.5V
The sense is 0.9 Amp On all the circuit : Read at the DC/DC stepdown output converter by the INA169 (Not good for me to read the sense in the signal itself).
The wire lenght is near 10Meters and i use 2 power resistor 10 and 12 ohm in serial.

Here the position of the receiver in the room:



Like Roland say Be carreful with the receiver output and due (3.3V).
In my scope it's sometime more than 4,5V.


Hope this can help.

By.
Folgende Benutzer bedankten sich: Rubberduck

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem to receive 5 Monate 2 Wochen her #16981

  • Rubberduck
  • Rubberducks Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 5
  • Dank erhalten: 0
Hi

Got my new coil from Marotronics today. And it works like a charm! Much higher values and the peek is longer. Only tested it in the garage but it looks promising. It turned out that my old coils that I have bought from Ebay didn´t have the correct value, it was 100 uH instead of 100 mH.

I´m using the MEGA, but now I have ordered a DUE so I could test the Raindancer firmware - it looks very interesting. Thanks for the heads up on the receiver output when connecting it to DUE.

As you pointed out I also had issues with noise - it was caused by two things, first was the USB connection and second was a long ground wire to the probe.

So big thanks two you both , Roland and Bernard , for helping me out. I appreciate it a lot!!

Bernard: about your WIFI or LORA communicating sender - what are you going to send over WIFI/LORA?

Best regards
Andreas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem to receive 5 Monate 2 Wochen her #16982

  • Bernard
  • Bernards Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 985
  • Dank erhalten: 186
Cool if the problem is solved.
See this post www.ardumower.de/index.php/en/forum/gene...er-area-mowing#16769
The mower use a raspberry pi and start or stop the sender over wifi when needed.
I use Esp32 because the esp8266 fail on 104 microsecond interrupt to send signal.
And the esp01 with nano is not very simple solution.

By.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
Ladezeit der Seite: 5.914 Sekunden