Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
Kinder lieben Musik! Mit der der ArduSoundBox gibt es nun eine tolle DIY Lösung für alle kleinen und großen Musikliebhaber.
  • Seite:
  • 1

THEMA: Upload auf Mega2560 funktioniert nicht

Upload auf Mega2560 funktioniert nicht 3 Jahre 8 Monate her #6304

  • twin850
  • twin850s Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 8
  • Dank erhalten: 0
Hallo,

ich beschäftige mich nun schon seit Wochen mit den theoretischen Grundlagen dieses Projekts und wollte nun endlich mal praktisch loslegen. Bin absoluter Arduino Newbie, jedoch im IT Bereich tätig, dachte also die Grundlagen wären für mich schon machbar. Also habe ich mir mir über den Shop erst einmal das Mega 2560 R3 Board und den Ardumower Mini besorgt, bekomme aber noch nicht einmal den immer erwähnten Beispiel Skretch "Blink" auf den Arduino.

Beim Upload flackern RX und TX auf dem Board kurzzeitig und danach kommt folgende Fehlermeldung:

avrdude: verification error, first mismatch at byte 0x0000
0x00 != 0x06
avrdude: verification error; content mismatch

Folgendes habe ich bereits erfolglos versucht:
-USB Kabel getauscht
-Software auf anderen PC / anderes Betriebssystem
-Diverse Revisionsstände der Arduino IDE Software
-richtigen Port und richtiges Board im IDE ausgewählt

Es hängt weiter noch nichts an dem Board. Nur das USB Kabel zum Recher. Mit seperater Stromversorgung klappt es auch nicht.

Meine bisherigen Recherchen haben leider zu keinem Ergebnis geführt.

Hat jemand von euch eine Idee oder kann es sein das das Board defekt ist ? Woran könnte man das erkennen ? Pwr LED und die gelbe "L" LED leuchten dauerhaft.

Vielen Dank

Jens
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Upload auf Mega2560 funktioniert nicht 3 Jahre 8 Monate her #6305

  • nero76
  • nero76s Avatar
  • Offline
  • Administrator
  • Administrator
  • cofounder of www.ardumower.de
  • Beiträge: 2303
  • Dank erhalten: 816
Hallo Jens,

es sieht danach aus als wenn der Bootloader nicht funktioniert (dies ist ein kleines Programm im Arduino Mega 2560 welches bei einem Reset ausgeführt wird und welches neue Programme in den Flash Speicher über die USB-Schnittstelle übertragen kann. Dieser Bootloader wurde von den Leuten des Arduino Projektes entwickelt und kann ggf. schon mal überschrieben werden wenn man falsche Einstellungen beim Upload eines Programms auswählt oder beim Einsatz falscher Upload-Software).

Den Bootloader neu zu flashen könnte das Problem lösen.

Der Bootloader kann meines Erachtens aber nicht über die USB-Schnittstelle übertragen werden, sondern nur über die ISP-Schnittstelle des Boards. Dazu braucht man entweder wieder einen Arduino (z.B. Nano)...

letsmakerobots.com/content/make-arduino-isp-programmer
www.martyncurrey.com/arduino-nano-as-an-isp-programmer/

...oder einen fertigen ISP Programmer:

cisana.net/burning-the-bootloader-onto-the-arduino-mega-2560/

Gruss,
Alexander

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PCB1.3 - die Plug&Play Robotik-Plattform für Deinen Rasenroboter mit passender Open Source Software

Upload auf Mega2560 funktioniert nicht 3 Jahre 8 Monate her #6307

  • twin850
  • twin850s Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 8
  • Dank erhalten: 0
Danke für die Antwort.

So was habe ich befürchtet. War auch der einzige brauchbare Hinweis den ich im Netz anderweitig gefunden habe.

Ok, dan bestellt ich jetzt gleich nochmal nen NANO (kann man ja mal liegen haben) und Versuch ein neues Flashen des Bootloaders.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Upload auf Mega2560 funktioniert nicht 3 Jahre 7 Monate her #6550

  • pemiso
  • pemisos Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 309
  • Dank erhalten: 40
Habe einen Mega als Perimetertestempfänger benutzt und in der Hand haltend über USB am Laptop hängend die Schleife getestet. Dabei die Bordrückseite mit der Hand berührt. Danach stand die serielle Übertragung. Seitdem geht die USB-Schnittstelle nicht mehr. Hat jemand einen Tip für mich?

Ist das Teil noch zu gebrauchen??? Danke und Gruß ... Peter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Denna RML100, 2x12V BleiGel Akku, PCB 0.5, Azurit
Original Ardumower, Ardumower LiIOn Akku, PCB 1.2, Azurit
iMow 632

Upload auf Mega2560 funktioniert nicht 3 Jahre 7 Monate her #6551

  • nero76
  • nero76s Avatar
  • Offline
  • Administrator
  • Administrator
  • cofounder of www.ardumower.de
  • Beiträge: 2303
  • Dank erhalten: 816
Bei mir war es ein "hochfrequenter" Motortest (hatte mit dem Motortreiber ENABLE-Signal gespielt) - danach funktionierte ebenfalls die USB-Schnittstelle des Mega nicht mehr. Anscheinend ist die empfindlich gegen hohe Frequenzen o.ä.?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PCB1.3 - die Plug&Play Robotik-Plattform für Deinen Rasenroboter mit passender Open Source Software
  • Seite:
  • 1
Ladezeit der Seite: 0.500 Sekunden