Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: PCB 1.3 | batVoltage: -43.89 beim Start

PCB 1.3 | batVoltage: -43.89 beim Start 1 Jahr 6 Monate her #14830

  • Joachim
  • Joachims Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 33
  • Dank erhalten: 5
Hallo,
mein neues RTC-Modul ist eingebaut, I2C-Scan liefert Adressen und mit arduremote geänderte Werte sind nach restart wieder verfügbar. ADC calibration habe ich auch gemacht.
Aber: Trotzdem bekomme ich beim Start des PCB einen ERR_BATTERY (siehe Auszug aus der seriellen Konsole). Ich habe mal Markierung in den screenshot der seriellen Konsole eingefügt. (But: while starting the PCB still gives an ERR_BATTERY, for details please see the screenshot)

Markierung 1: RTC Datum wird geliefert, aber "batVoltage" hat einen Wert von -43.89. Demzufolge wird ein Batteriefehler im Errorcounter gesetzt.
...
checkBattery(){
if (millis() < nextTimeCheckBattery) return;
	nextTimeCheckBattery = millis() + 1000;  
  if (batMonitor){
    if ((batVoltage < batSwitchOffIfBelow) && (idleTimeSec != BATTERY_SW_OFF)) {  
	  Console.println(F("Battery warning: triggered batSwitchOffIfBelow"));
      addErrorCounter(ERR_BATTERY);      
	  ...
Markierung 2: in der Statuszeile werden Werte fürs chg und Imu angezeigt.
Markierung 3: ERR_BATTERY wird ausgegeben.
Markierung 4: Jetzt ist batVoltage ok, chg ist noch falsch
Markierung 5: Jetzt scheinen die Werte ok zu sein

Wenn ich dann die Fehler lösche, kommt auch kein neuer Batteriefehler, was mir auch logisch erscheint, denn die Batteriewerte stimmen ja jetzt. (when errors are deleted, no new errors for batterie occur)

Hat jemand eine Idee für mich, woher beim Start die -43V kommen könnten :) ?
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PCB 1.3 | batVoltage: -43.89 beim Start 1 Jahr 6 Monate her #14840

  • elektronikjogi
  • elektronikjogis Avatar
  • Offline
  • Administrator
  • Administrator
  • Beiträge: 285
  • Dank erhalten: 267
Hallo Joachim,
der Fehler kommt vermutlich eine falsche ADC Kalibrierung bzw. falsche Werte mit denen zu diesem Zeitpunkt noch gearbeitet wurde.

Gruß
Jürgen

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PCB 1.3 | batVoltage: -43.89 beim Start 1 Jahr 6 Monate her #14847

  • Joachim
  • Joachims Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 33
  • Dank erhalten: 5
Hallo Jürgen,
danke, ich versuche das mal einzugrenzen.
Gruss Joachim

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
Moderatoren: runtimeterror
Ladezeit der Seite: 1.986 Sekunden