Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: Erste Tests von PCB 1.3, anweisungen

Erste Tests von PCB 1.3, anweisungen 1 Jahr 6 Monate her #14615

  • PeteLake
  • PeteLakes Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 71
  • Dank erhalten: 8
Erste Tests von PCB 1.3 (wie in Video 7 gezeigt)

- Setzen Sie die Sicherung 1.6AT (vorläufig) in den Sicherungshalter EF2 ein.
- Stecken Sie den DC / DC-Wandler ein
- Schließen Sie nicht JP1 an
- Schließen Sie JP8 an Dauer-ON an
- Schließen Sie das Verbindungskabel für den Start-Button an und verbinden Sie die Drahtenden
- Anschließen der Batterie mit P43 (Uhr + und -)
- Spannung messen
- Reduzieren Sie die Spannung auf 9 V bei DC / DC
- Die Batteriekontroll-LED (+ 24V) muss eingeschaltet sein
- Schließen Sie JP1 an
- Kontroll-LEDs "+ 5VP" und "+ 3.3Vp" müssen aufleuchten
- Trennen Sie die Batterie und entfernen Sie das Messgerät
- Überbrücken Sie die NOT-AUS-Verbindung mit einer Drahtbrücke
- Bringen Sie die Batterie wieder an
- Kontroll-LEDs "Dual1" und "Dual2" müssen aufleuchten
- Trennen Sie die Batterie wieder
- Schließen Sie die Motortreiber an
- Bringen Sie die Batterie wieder an
- Alle Kontroll-LEDs leuchten wie zuvor
- Trennen Sie die Batterie wieder
- Mount Arduino (JP13 für Marotronics DUE (Klon))
- Bringen Sie die Batterie wieder an
- Die LEDs "+ 3.3V" und "+ 5V" leuchten jetzt auf (alle Kontroll-LEDs leuchten) und der Piepton ertönt kontinuierlich
- Trennen Sie die Batterie wieder
- Ziehen Sie die Sicherung von 1.6AT nach EF1 und stecken Sie die Sicherung 5AT in EF2
- Setzen Sie INA, Relais und RTC ein
- Bringen Sie die Batterie wieder an
- Platziere den Bargraph (wähle die richtige Richtung)
- Erste LED (Station LED) und letzte LED (Buzzer) Burn und Buzzer piepst kontinuierlich
(Auf dem Video blinkt die 4e LED, anscheinend durch das "BLINK" -Programm auf dem DUE, das war es nicht so mit mir, trotz der blinkenden Programm auf Pin13 von Arduino konzentriert ... ???)
! Oh ja, ich habe noch nicht die Drahtbrücken für die Teiler gelötet, ich möchte zuerst die Odometrie studieren ...
Oder ist das ein Problem, um fortzufahren?

Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Erste Tests von PCB 1.3, anweisungen 1 Jahr 6 Monate her #14616

  • PeteLake
  • PeteLakes Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 71
  • Dank erhalten: 8
Wer kann mir sagen, was die nächsten Schritte sind?
.INO Sketch von Arduino?
(ardumower-1.0a7-Azurit \ ardumower-1.0a7-Azurit \ code \ ardumower \ ardumower.ino)
Und sollten alle .h und .cpp Dateien auch irgendwo in der Arduino IDE kopiert werden?

Wann sollte der Startknopf (P20) platziert werden?
Ist das ein An / Aus, oder ein Druckknopf, der zurückspringt?
Sollte die Drahtbrücke des NOT-Aus noch bestehen bleiben?

Was sind die nächsten Tests, bevor ich die Motoren und die Sensoren anschließe?

Grtjs, Peter aus Brügge (Belgien)

PS: Kann ich persönlich jemanden kontaktieren, wenn ich eine kleine oder dumme Frage habe?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Erste Tests von PCB 1.3, anweisungen 1 Jahr 6 Monate her #14619

  • Roland
  • Rolands Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 722
  • Dank erhalten: 244
Wann sollte der Startknopf (P20) platziert werden?
=> P20 wird nur benötigt, wenn man die Undervoltageabschaltung aktivieren möchte. Für erste Tests einfach schließen.

Ist das ein An / Aus, oder ein Druckknopf, der zurückspringt?
=> Wie du möchtest. Ich verwende ein ein/aus Schalter, damit ich diesen für Tests überbrücken kann.

Sollte die Drahtbrücke des NOT-Aus noch bestehen bleiben?
=> Ja, ohne Brücke bekommen die Motoren keinen Strom

Was sind die nächsten Tests, bevor ich die Motoren und die Sensoren anschließe?
Ich würde als erstet Teilfunktionen testen. Laufen die Motoren, ist die RTC ansprechbar, funktioniert das BT Modul.

Da ich die original Software nicht verwende, kann ich dich hier nur auf einen Link verweisen, wo diverse
Testroutinene hinterlegt sind.
github.com/Ardumower/ardumower/tree/master/code/tests

Ansonsten hat mein Raindancer Code viele Testfunktionen enthalten. Da kann ich dir mehr zu sagen wenn du probieren möchtest. Würde mich auch mal interessieren, ob dieser Code woanders compiliert und funktioniert.
Terminal auf 115200 stellen und H für Hilfe eingeben. Den Text dann am besten in einen Editor kopieren.

github.com/kwrtz/Raindancer/tree/master/code

Motor links direkt ansteuern Befehl: clc.mt,1,60
Motor rechts direkt ansteuern Befehl: clc.mt,2,60
Encoder Werte anzeigen mit: clc.enc
Test beenden mit: clc.mt,0,0
Ecoderwerte ausblenden mit: h

I2C scannen mit: i2c.scan
RTC setzen mit: rtc.set,8,17,3,25,01,2017 (Bedeutung: set rtc time=8:17 dayOfWeek=3 date=25.01.20179
RTC auslesen mit: rtc.show (wird vermutlich erst funktionieren, wenn du das rtc modul beschrieben hast.)

Wenn du möchtest, kannst du mich über Skype kontaktieren. Bei Hardware kann ich dir dann ggf. helfen. Bei dem original Ardumowercode nur eingeschränkt. Da haben andere sich mehr mit befasst als ich.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

"There’s a way to do it better - find it" ― Thomas A. Edison

Erste Tests von PCB 1.3, anweisungen 1 Jahr 3 Monate her #15425

  • aswitcom
  • aswitcoms Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Elektronik, Mikrocontroller Hobby
  • Beiträge: 64
  • Dank erhalten: 0
Hallo Roland,

mein PCB1.3 läuft wunderbar, habe den Vorgänger PCB1.2 ersetzt, da mir dieser von Anfang an Probleme machte.

Jetzt habe ich folgende Frage, es ist ja eine 5A und eine 1.6A Sicherung verbaut.

Die 1.6AT ist mir jetzt bereits das 2.mal durchgegangen. Der Mower lief dabei einmal unter die Hecke (Manuellbetrieb) und das zweite mal (Autobetrieb) fuhr er an den Baum und grub sich im Sand ein, wobei das Mähwerk an den Steinen streifte.

Soll ich das höher absichern oder so lassen. Im Normalfall sollte die 1.6 ja halten?

Liebe Grüße,
Karl-Heinz
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

ArduMower PCB1.2 & PCB 1.3, FreeCAD, 3D Print, Eagle & Ki-Cad, Arduino, CNC Lasergravur, Fräser

Erste Tests von PCB 1.3, anweisungen 1 Jahr 3 Monate her #15434

  • Roland
  • Rolands Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 722
  • Dank erhalten: 244
Hallo Karl-Heinz,

ich weiß aktuell nicht, wo du die 1,6A eingebaut hast.
Aber: die Standardsicherung EF2 sollte 10A betragen. Die Ladesicherung EF1 5A.
Hier ist zu berücksichtigen, dass wenn du den Mower ausgeschlatet hast (also Batterie nicht angeklemmt) und dann an P42 Charger eine Ladespannung dranhängst,
wird das Board über D73 direkt mit Spannung versorgt. Das Problem ist, das die Kondensatoren keine Spannung haben und beim Anklemmen einen Kurzschluss liefern. Dann wird die eine 1,6A Sicherung in EF1 durchschlagen.
Ich habe bei mir die D73 rausgenommen, da ich diese nur dann für sinnig halte, wenn die Undervoltagabschaltung aktiviert wurde. Falls dies mal wirklich passiert, werde ich einfach die Batterie direkt mit dem Ladegerät laden. Sowas sollte nur im Fehlerfall passieren und nicht die Regel sein.
Weiterhin hat die D73 ein anders Potential auf der Hinterseite, als die Dioden die hinter dieser eingelötet sind. Da ist es sinnig, diese mit Heißkleber zu trennen, nicht das diese aneinander kommen.

Viele Grüße
Roland
Folgende Benutzer bedankten sich: aswitcom

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

"There’s a way to do it better - find it" ― Thomas A. Edison
Letzte Änderung: von Roland.

Erste Tests von PCB 1.3, anweisungen 1 Jahr 3 Monate her #15442

  • aswitcom
  • aswitcoms Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Elektronik, Mikrocontroller Hobby
  • Beiträge: 64
  • Dank erhalten: 0
Hallo Roland,

vielen herzlichen Dank für die Antwort, ja dann habe ich den Fehler, da hat mir Markus aus dem Shop ein Ei in die Bauteile gelegt, da war eine 5A und eine 1.6A Sicherung dabei und als die 5A verbaut war schaute ich sicherlich nicht mehr auf den Schaltplan, bzw. Layout.

Dann halten die 1.6 statt 10 Ampere ja e relativ gut. :-)

Ich habe die D73 drinnen, Ladestation ist noch in Planung, aktuell hänge ich noch draussen das Ladegerät dran. Soll sich aber in den nächsten Tagen ändern.

Liebe Grüße,
Karl-Heinz
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

ArduMower PCB1.2 & PCB 1.3, FreeCAD, 3D Print, Eagle & Ki-Cad, Arduino, CNC Lasergravur, Fräser

Erste Tests von PCB 1.3, anweisungen 1 Jahr 3 Monate her #15572

  • runtimeterror
  • runtimeterrors Avatar
  • Offline
  • Moderator
  • Moderator
  • Beiträge: 116
  • Dank erhalten: 26
Also bei mir waren auch 1,6 A und 5 A im Paket. Laut Video ist das auch richtig so:



Falls das nicht korrekt ist, würde ich gerne wissen, wo der aktuelle Stand dokumentiert ist. Im Wiki habe ich auch nichts gefunden.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Erste Tests von PCB 1.3, anweisungen 1 Jahr 3 Monate her #15573

  • Roland
  • Rolands Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 722
  • Dank erhalten: 244
Es ist richtig, dass diese Sicherungen mitgeliefert wurden und im Video auch eingesetzt wurde. Aber so funktioniert es nicht. Habe das selber getestet. Den Rest habe ich oben erklärt. Die Sicherungen sollten dazu da sein, um Fehler abzufangen und nicht an der Grenze des Durchschmelzen zu arbeiten.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

"There’s a way to do it better - find it" ― Thomas A. Edison
Letzte Änderung: von Roland.

Erste Tests von PCB 1.3, anweisungen 1 Jahr 3 Monate her #15574

  • Flyfast
  • Flyfasts Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 47
  • Dank erhalten: 3
So, it means that 5amps and 10amps the correct value for those fuses?
There is no Informationen given from the video nor in the WIKI.
Nice to know.
Uwe

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Erste Tests von PCB 1.3, anweisungen 1 Jahr 3 Monate her #15579

  • Roland
  • Rolands Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 722
  • Dank erhalten: 244
Sorry, I forgot to mention take a look in the schematics on the first side. There stands the values. I don't no why there are 5/10A and they sell 1.6/5A.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

"There’s a way to do it better - find it" ― Thomas A. Edison
  • Seite:
  • 1
Moderatoren: runtimeterror
Ladezeit der Seite: 0.648 Sekunden