Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: Communications Menu

Communications Menu 3 Jahre 3 Wochen her #10425

  • Ardumäher
  • Ardumähers Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 3
  • Dank erhalten: 0
Hi, ihr habt mich mit eurem Projekt begeistert und nun habe ich auch einen adrumower gebaut. Zumindest ist die Hardware soweit fertig das ich die Software aufspielen will. Das ist mir auch (teilweise?)gelungen aber da ich nach dem Einschalten Fehlermeldungen bekomme und der Sache nachgehen will versuche ich über das Terminal den "console output" mit eingabe "v" zu nutzen aber das funktioniert nicht. Also dachte ich daran das Bluetooth modul zu nutzen und hab mir die pfodApp installiert. Nun musste ich aber feststellen das das nicht so einfach funktioniert und man noch was einstellen muss und zwar im Communications Menu in der Konsole. Nur leider passiert nichts wenn ich die "3" eingebe. Was mache ich denn falsch?

Ich benutze arduino 1.6.3 und ardumower-1.0a6-Azurit. Mit arduino 1.6.12 habe ich fehlermeldungen beim Kopilieren bekommen.

Hier mal die Ausgabe:
--- Start of recording: 28.09.2016 17:39:40 ---
SETUP
ADCMan: found calib data
---ADC calib---
ADC sampleRate=38462
AD0 min=9999 max=-9999 diff=-19998 ofs=0
AD1 min=9999 max=-9999 diff=-19998 ofs=0
AD2 min=9999 max=-9999 diff=-19998 ofs=0
AD3 min=9999 max=-9999 diff=-19998 ofs=0
AD4 min=9999 max=-9999 diff=-19998 ofs=578
AD5 min=9999 max=-9999 diff=-19998 ofs=84
AD6 min=9999 max=-9999 diff=-19998 ofs=0
AD7 min=9999 max=-9999 diff=-19998 ofs=0
AD8 min=9999 max=-9999 diff=-19998 ofs=402
AD9 min=9999 max=-9999 diff=-19998 ofs=0
AD10 min=9999 max=-9999 diff=-19998 ofs=0
AD11 min=9999 max=-9999 diff=-19998 ofs=0
AD12 min=9999 max=-9999 diff=-19998 ofs=0
AD13 min=9999 max=-9999 diff=-19998 ofs=0
AD14 min=9999 max=-9999 diff=-19998 ofs=0
AD15 min=9999 max=-9999 diff=-19998 ofs=0
matchSignal size=24
subSample=4
capture size=192
IMU error: no calib data
accOfs=0.00,0.00,0.00
accScale=2.00,2.00,2.00
comOfs=0.00,0.00,0.00
comScale=2.00,2.00,2.00
initL3G4200D
gyro read error
gyro read error
gyro read error
loadSaveErrorCounters: read
loadSaveErrorCounters addrstop=422
loadUserSettings
loadSaveUserSettings addrstop=263
loadSaveRobotStats: read
loadSaveRobotStats addrstop=822
START
Ardumower 1.0a6-Azurit
Config: Ardumower
press...
d for menu
v to change console output (sensor counters, values, perimeter etc.)
sen_counters

MAIN MENU:
1=test motors
2=test odometry
3=communications menu
5=calibrate IMU acc next side
6=calibrate IMU com start/stop
7=delete IMU calib
8=ADC calib (perimeter sender, charger must be off)
9=save user settings
l=load factory settings
r=delete robot stats
x=read settings
e=delete all errors
0=exit

in der mover.ccp habe ich vorher die einsellungen wie beschrieben in der "erst Inbetriebnahme" gemacht

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Communications Menu 3 Jahre 3 Wochen her #10426

  • Ardumäher
  • Ardumähers Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 3
  • Dank erhalten: 0
achso das habe ich noch vergessen:

1=test motors (OK)
2=test odometry (nicht angeschlossen)
3=communications menu (keine Reaktion bzw. menu kommt erneut)
5=calibrate IMU acc next side (nicht angeschlossen)
6=calibrate IMU com start/stop (nicht angeschlossen)
7=delete IMU calib (nicht angeschlossen)
8=ADC calib (perimeter sender, charger must be off) (funktioniert)
9=save user settings (funktioniert)
l=load factory settings (funktioniert)
r=delete robot stats (nich probiert)
x=read settings (funktioniert)
e=delete all errors (funktioniert)
0=exit

hier die ausgelesenen settings:

wheel motors
motorAccel : 1000.00
motorSpeedMaxRpm : 25
motorSpeedMaxPwm : 255
motorPowerMax : 75.00
motorSenseRightScale : 15.30
motorSenseLeftScale : 15.30
motorPowerIgnoreTime : 2000
motorZeroSettleTime : 3000
motorRollTimeMax : 1500
motorRollTimeMin : 750
motorReverseTime : 1200
motorForwTimeMax : 80000
motorBiDirSpeedRatio1 : 0.30
motorBiDirSpeedRatio2 : 0.92
motorLeftPID.Kp : 1.50
motorLeftPID.Ki : 0.29
motorLeftPID.Kd : 0.25
motorRightSwapDir : 0
motorLeftSwapDir : 0
mower motor
motorMowAccel : 2000.00
motorMowSpeedMaxPwm : 255
motorMowPowerMax : 75.00
motorMowModulate : 0
motorMowRPMSet : 3300
motorMowSenseScale : 15.30
motorMowPID.Kp : 0.00
motorMowPID.Ki : 0.01
motorMowPID.Kd : 0.01
motorMowModulate Interrupt
motorMowModulate Interrupt : 0
bumper
bumperUse : 0
drop
dropUse : 0
dropContact : 1
rain
rainUse : 0
sonar
sonarUse : 0
sonarLeftUse : 1
sonarRightUse : 1
sonarCenterUse : 0
sonarTriggerBelow : 1050
perimeter
perimeterUse : 0
perimeterTriggerTimeout : 0
perimeterOutRollTimeMax : 2000
perimeterOutRollTimeMin : 750
perimeterOutRevTime : 2200
perimeterTrackRollTime : 1500
perimeterTrackRevTime : 2200
perimeterPID.Kp : 51.00
perimeterPID.Ki : 12.50
perimeterPID.Kd : 0.80
trackingPerimeterTransitionTimeOut : 2000
trackingErrorTimeOut : 10000
trackingBlockInnerWheelWhilePerimeterStruggling : 1
lawn sensor
lawnSensorUse : 0
IMU (compass/accel/gyro)
imuUse : 0
imuCorrectDir : 0
imuDirPID.Kp : 5.00
imuDirPID.Ki : 1.00
imuDirPID.Kd : 1.00
imuRollPID.Kp : 0.80
imuRollPID.Ki : 21.00
imuRollPID.Kd : 0.00
model R/C
remoteUse : 0
model R/C Interrupt
Pin 10 pinRemoteSpeed : 0
Pin 11 pinRemoteSteer : 0
Pin 12 pinRemoteMow : 0
Pin 52 pinRemoteSwitch : 0
battery
batMonitor : 0
batGoHomeIfBelow : 10.50
batSwitchOffIfBelow : 10.00
batSwitchOffIfIdle : 1
batFactor : 0.50
batChgFactor : 0.50
batFull : 12.00
batChargingCurrentMax : 4.00
batFullCurrent : 0.30
startChargingIfBelow : 11.00
chargingTimeout : 12600000
chgSelection : 2
chgSenseZero : 511.00
chgFactor : 39.00
chgSense : 185.00
chgChange : 0
chgNull : 2
charging station
stationRevTime : 1800
stationRollTime : 1000
stationForwTime : 1500
stationCheckTime : 1700
odometry
odometryUse : 0
twoWayOdometrySensorUse : 0
odometryTicksPerRevolution : 1060
odometryTicksPerCm : 13.49
odometryWheelBaseCm : 36.00
odometryRightSwapDir : 0
odometryLeftSwapDir : 1
Odometry Interrupt
oneway left : 0
Oneway right : 0
twoway left : 0
twoway right : 0
GPS
gpsUse : 0
stuckIfGpsSpeedBelow : 0.20
gpsSpeedIgnoreTime : 5000
other
buttonUse : 1
user-defined switch
userSwitch1 : 0
userSwitch2 : 0
userSwitch3 : 0
timer
timerUse : 0
bluetooth
bluetoothuse : 0
esp8266
esp8266Use : 0
esp8266ConfigString : 123test321
robot stats
statsMowTimeMinutesTrip : 0
statsMowTimeMinutesTotal : 0
statsBatteryChargingCounterTotal : 0
statsBatteryChargingCapacityTrip in mAh : 0.00
statsBatteryChargingCapacityTotal in Ah : 0.00
statsBatteryChargingCapacityAverage in mAh : 0.00
loadSaveRobotStats: write
loadSaveRobotStats addrstop=822
ALL ROBOT STATS ARE DELETED

MAIN MENU:
1=test motors
2=test odometry
3=communications menu
5=calibrate IMU acc next side
6=calibrate IMU com start/stop
7=delete IMU calib
8=ADC calib (perimeter sender, charger must be off)
9=save user settings
l=load factory settings
r=delete robot stats
x=read settings
e=delete all errors
0=exit

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Communications Menu 3 Jahre 3 Wochen her #10427

  • nero76
  • nero76s Avatar
  • Offline
  • Administrator
  • Administrator
  • cofounder of www.ardumower.de
  • Beiträge: 2307
  • Dank erhalten: 818
Du müsstest in der mower.cpp "bluetoothUse = 1" setzen damit er das Menü anzeigt.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PCB1.3 - die Plug&Play Robotik-Plattform für Deinen Rasenroboter mit passender Open Source Software
Letzte Änderung: von nero76.

Communications Menu 3 Jahre 2 Wochen her #10428

  • Ardumäher
  • Ardumähers Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 3
  • Dank erhalten: 0
hab ich eigentlich eingestellt aber in den settings steht 0, nochmal alles durch geguckt unter anderem festgestellt das ich ausversehen bei der Akkuspannung 12,4 geschrieben hab und nicht 12.4
Hab es nochmal eingespielt und user settings geladen. GEHT!! erst mal kommt das menu und die ausgaben

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
Moderatoren: runtimeterror
Ladezeit der Seite: 0.408 Sekunden