Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: Problem mit Inbetriebnahme

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9789

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Hallo ich heiße Björn,
ich habe mir ein Mower aufgebaut.
Gesteuert mit Sainsmart mega2560,
L298 Steuerung, 2 Getriebe Motoren 12 V,(Alles was ich noch liegen hatte. ) Mähwerk ist zur zeit noch nicht dran.
bin nach "Inbetriebnahme Leitfaden" vor gegangen.
Mower.cpp ist angepasst an L298N und entspechend der Tabelle die USE Parameter gesetzt.
Der Mower soll einfach nur mähen bis er an der Rasenkante anstösst. Brauch keine Schleife oder Ähnliches.
Nach dem Einschalten,läuft der rechte motor vorwärts sonst passiert nix.
Motoren können am L298 jeweils vor und Rückwärts gesteuert werden.

Fehler laut Console ist:
SETUP
ADCMan error: no calib data
matchSignal size=24
subSample=4
capture size=192
loadSaveErrorCounters: read
loadSaveErrorCounters addrstop=422
loadUserSettings
EEPROM USERDATA: NO EEPROM USER DATA
PLEASE CHECK AND SAVE YOUR SETTINGS
t 0 l 0 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 0.0 chg 0.0 0.0 imu 0 adc 0 Ardumower
loadSaveRobotStats: read
loadSaveRobotStats addrstop=822
START
Ardumower 1.0a5-Azurit
Config: Ardumower
press...
d for menu
v to change console o

Braucht der noch n externes Eeprom oder oder ist der Arduino nicht geeignet ?
oder muss noch wo anders auf L298 umgestellt werden?

Danke schon mal für eure Hilfe.
Gruß aus Bremervörde

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9795

  • Paddy
  • Paddys Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 459
  • Dank erhalten: 206
Hallo,

hast du mal in der Konsole die Motoren getestet? Dazu Notebook an den USB Port, serieller Monitor aufmachen und "d" eintippen. Dort gibt es irgendwo einen Motortest.

Gemäß den Fehlermeldungen hast du keinen ADC Abgleich gemacht? Dies muss zwingend erfolgen. Geht ebenfalls über das Menü oder über Bluetooth.
Zum EEPROM, dieser ist Bestandteil des Arduino. Nachdem du Einstellungen über Handy oder Konsole gemacht hast, müssen diese gespeichert werden. Geht wiederrum z.B. über die Konsole.

Ich verwende auch die L298N, im Code muss lediglich der Aufruf in der Mower.cpp angepasst werden. Wenn sich nur einer dreht, vergewissere dich, ob der andere an den korrekten PINs angeschlossen ist.

Was für eine PLatine nutzt du? Selbstbau, Shield oder die PCB 1.2?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Tianchen TC-158N umgebaut auf Ardumower 1.0a10-dev Azurit
Klarstein Cleantouch Staubsauger umgebaut auf Ardumower 1.0a5 Azurit
Ardumower Arctic Hare

www.weberpatrick.de

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9798

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Ist ein Selbstbaushield. (lochraster)
Ist das normal das man in der Konsole nix richtig sieht ?
Es kommt kein Menü, nur das was ich schon gepostet habe, immer wiederholt.
Laut Anleitung soll das D und dann die 1 sein.
In der Konsole ändert sich aber nix.... also komme ich auch nicht auf den ADC abgleich...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9799

  • pemiso
  • pemisos Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 309
  • Dank erhalten: 41
Hi Björn,

nur der Vollständigkeit halber - ich bin halt ein Erbsenzähler :-) - Du hast 'd' und Entertaste eingegeben?! Jeder Befehl muß mit Entertaste quittiert werden ...

Gruß
Peter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Denna RML100, 2x12V BleiGel Akku, PCB 0.5, Azurit
Original Ardumower, Ardumower LiIOn Akku, PCB 1.2, Azurit
iMow 632

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9800

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Hab jetzt in der Konsole auf ""sowohl NL als auch CR"" gestellt jetzt komme ich ins Menü.
hab den Motorentest laufen lassen
links rechts zurück geht... vor piept nur
ADC durchgeführt
jetzt wartet er auf irgend was
Konsole zeigt jetzt gyro read error
danach jede menge Hieroglyphen.
ich muss noch mal den aufbau prüfen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9802

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Mal verständnishalber:
L298 ist ne H brücke.
also 1= h wäre vor
2= h räre rück

müssten dann nicht beide anschlüsse auf PWM gelegt werden ?
also wenn ich die Brücke oben und unten einschalte gibt es ein Kurzschluss.

Oder hab ich das nicht begriffen.

aus der mower.cpp lese ich PWM an für speed und dir H für richtungswechsel
da wäre aber die obere und die untere brücke an...
also vor ist pwm an dir aus
für Rück ist dir an und pwm ??? da müsse doch nur rück kommmen

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9804

  • Paddy
  • Paddys Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 459
  • Dank erhalten: 206
Hi,

hast du die L298N korrekt angeschlossen? Hier ist die Logik beschrieben. (der Teil mit Verdrahtung L298N)

ardumower.de/index.php/de/2014-09-11-11-...9-49-18/motortreiber

Auch das Parallelschalten der H Brücke bitte nicht vergessen (ebenfalls auf der Seite beschrieben

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Tianchen TC-158N umgebaut auf Ardumower 1.0a10-dev Azurit
Klarstein Cleantouch Staubsauger umgebaut auf Ardumower 1.0a5 Azurit
Ardumower Arctic Hare

www.weberpatrick.de
Letzte Änderung: von Paddy.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9805

  • Paddy
  • Paddys Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 459
  • Dank erhalten: 206
PS: Nach dem ADC Abgleich wartet er auf nichts. Es wird lediglich das Menü nicht erneut ausgegeben. Du kannst einfach weitere Kommandos übergeben, er reagiert sofort. Ich habe mich auch gewundert als ich mit dem Ardumower angefangen habe.

Zum Gyro read error, hast du überhaupt einen Gyro verbaut? Wenn nicht, muss dieser im Code oder über die Handy-App auch deaktiviert werden.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Tianchen TC-158N umgebaut auf Ardumower 1.0a10-dev Azurit
Klarstein Cleantouch Staubsauger umgebaut auf Ardumower 1.0a5 Azurit
Ardumower Arctic Hare

www.weberpatrick.de

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9807

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Gyro ist nicht verbaut muss nochmal geprüft werden.
Shield habe ich entfernt. gibt wieder Fädelverbau. kann besser geändert werden.
Motoren drehen jetzt vor und zurück. allerdings ist nun durchs testen der Akku leer.
Motor hat auch keine Stromsensoren. Das muss ich noch nachholen(hab ja zeit bis der akku wieder voll ist).
Die Parallelschaltung der Brücke habe ich nicht, da meine Getriebemotoren einen blockierstom von 1,2 A ziehen....

Daher ist für heute hier Pause.
Allen erst mal vielen Dank für die Tips.

Gruß Björn

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9824

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
So Motorstrom der Antriebsmotoren wird nun gemessen. Allerdings habe ich im Fahrbetrieb auf Gras für beide etwa 150 mA
(im Manuellen Betrieb über Taster) wenn ich den Arduino anschließe, Motortest laufen lasse, dann drehen die Motoren vor und zurück. dann piept er 4 mal im Abstand von etwa 5 sek. Mehr passiert nicht. Mähmotor ist noch nicht verbaut.
Inbetribname ist nach anleitung durch.Gibt es irgendwo noch ein Schalter der den Gyro ausschaltet oder muss ich einen verbauen? muss die RTC und das Bluetooth modul montiert sein ??
Immer wieder taucht gyro read error auf obwohl ich alles durchsucht habe und jeden aufruf auskommentiert. Noch jemand ne idee? Hier nochmal der auszug aus dem Terminal:

SETUP
ADCMan: found calib data
---ADC calib---
ADC sampleRate=38462
AD0 min=9999 max=-9999 diff=-19998 ofs=385
AD1 min=9999 max=-9999 diff=-19998 ofs=0
AD2 min=9999 max=-9999 diff=-19998 ofs=0
AD3 min=9999 max=-9999 diff=-19998 ofs=0
AD4 min=9999 max=-9999 diff=-19998 ofs=344
AD5 min=9999 max=-9999 diff=-19998 ofs=366
AD6 min=9999 max=-9999 diff=-19998 ofs=0
AD7 min=9999 max=-9999 diff=-19998 ofs=0
AD8 min=9999 max=-9999 diff=-19998 ofs=413
AD9 min=9999 max=-9999 diff=-19998 ofs=0
AD10 min=9999 max=-9999 diff=-19998 ofs=0
AD11 min=9999 max=-9999 diff=-19998 ofs=0
AD12 min=9999 max=-9999 diff=-19998 ofs=0
AD13 min=9999 max=-9999 diff=-19998 ofs=0
AD14 min=9999 max=-9999 diff=-19998 ofs=0
AD15 min=9999 max=-9999 diff=-19998 ofs=0
matchSignal size=24
subSample=4
capture size=192
IMU error: no calib data
accOfs=0.00,0.00,0.00
accScale=2.00,2.00,2.00
comOfs=0.00,0.00,0.00
comScale=2.00,2.00,2.00
initL3G4200D
gyro read error
gyro read error
gyro read error
loadSaveErrorCounters: read
loadSaveErrorCounters addrstop=422
loadUserSettings
loadSaveUserSettings addrstop=263
loadSaveRobotStats: read
loadSaveRobotStats addrstop=822
START
Ardumower 1.0a6-Azurit
Config: Ardumower
press...
d for menu
v to change console output (sensor counters, values, perimeter etc.)
sen_counters
output (sensor count

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9825

  • nero76
  • nero76s Avatar
  • Offline
  • Administrator
  • Administrator
  • cofounder of www.ardumower.de
  • Beiträge: 2307
  • Dank erhalten: 818
Gyro Error direkt beim Start bedeutet es wurde kein Gyro gefunden. Alles korrekt wenn kein Gyro angeschlossen ist. Kann also ignoriert werden.

RTC und Bluetooth müssen nicht montiert sein, Bluetooth ist aber extrem hilfreich zum Fein-Einstellen aller Parameter.

Wie geht denn die Console weiter - und was genau ist dein Ziel (dein Motortest geht ja anscheinend). Wie sieht die Console aus wenn der Roboter normal über Taster losgeschickt wird. Und welche Sensoren sollten Deiner Meinung nach dann bei Hindernissen ansprechen (Vermutlich der Motorstrom - den Motorstrom für Hindernisse 'motorPowerMax' kannst Du z.B. über die Handy-App einstellen falls man nicht jedes mal den Wert 'motorPowerMax' in mower.cpp anpassen möchte).

Weitere Console-Ausgaben von der konkreten Situation (wo der Roboter sich nicht wie erwartet verhält) wären hilfreich :-)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PCB1.3 - die Plug&Play Robotik-Plattform für Deinen Rasenroboter mit passender Open Source Software
Letzte Änderung: von nero76.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9826

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Also ich schalte den mower ein, verbinde mit dem Laptop.Konsole an. Immer wenn setup erscheint piept er. etwa kurz nach dem 2. piepen drücke ich den Start taster. Mower soll losfahren bis bumper(taster) auslöst, dann Richtungswechsel und weiter. Bewegt sich aber nicht!
in der konsole zeigt sich : (von etwa 10 Sek gesampelt)

SETUP
ADCMan: found calib data
---ADC calib---
ADC sampleRate=38462
AD0 min=9999 max=-9999 diff=-19998 ofs=385
AD1 min=9999 max=-9999 diff=-19998 ofs=0
AD2 min=9999 max=-9999 diff=-19998 ofs=0
AD3 min=9999 max=-9999 diff=-19998 ofs=0
AD4 min=9999 max=-9999 diff=-19998 ofs=344
AD5 min=9999 max=-9999 diff=-19998 ofs=366
AD6 min=9999 max=-9999 diff=-19998 ofs=0
AD7 min=9999 max=-9999 diff=-19998 ofs=0
AD8 min=9999 max=-9999 diff=-19998 ofs=413
AD9 min=9999 max=-9999 diff=-19998 ofs=0
AD10 min=9999 max=-9999 diff=-19998 ofs=0
AD11 min=9999 max=-9999 diff=-19998 ofs=0
AD12 min=9999 max=-9999 diff=-19998 ofs=0
AD13 min=9999 max=-9999 diff=-19998 ofs=0
AD14 min=9999 max=-9999 diff=-19998 ofs=0
AD15 min=9999 max=-9999 diff=-19998 ofs=0
matchSignal size=24
subSample=4
capture size=192
IMU error: no calib data
accOfs=0.00,0.00,0.00
accScale=2.00,2.00,2.00
comOfs=0.00,0.00,0.00
comScale=2.00,2.00,2.00
initL3G4200D
gyro read error
gyro read error
gyro read error
loadSaveErrorCounters: read
loadSaveErrorCounters addrstop=422
loadUserSettings
loadSaveUserSettings addrstop=263
loadSaveRobotStats: read
loadSaveRobotStats addrstop=822
START
Ardumower 1.0a6-Azurit
Config: Ardumower
press...
d for menu
v to change console outpuSETUP
ADCMan: found calib data
---ADC calib---
ADC sampleRate=38462
AD0 min=9999 max=-9999 diff=-19998 ofs=385
AD1 min=9999 max=-9999 diff=-19998 ofs=0
AD2 min=9999 max=-9999 diff=-19998 ofs=0
AD3 min=9999 max=-9999 diff=-19998 ofs=0
AD4 min=9999 max=-9999 diff=-19998 ofs=344
AD5 min=9999 max=-9999 diff=-19998 ofs=366
AD6 min=9999 max=-9999 diff=-19998 ofs=0
AD7 min=9999 max=-9999 diff=-19998 ofs=0
AD8 min=9999 max=-9999 diff=-19998 ofs=413
AD9 min=9999 max=-9999 diff=-19998 ofs=0
AD10 min=9999 max=-9999 diff=-19998 ofs=0
AD11 min=9999 max=-9999 diff=-19998 ofs=0
AD12 min=9999 max=-9999 diff=-19998 ofs=0
AD13 min=9999 max=-9999 diff=-19998 ofs=0
AD14 min=9999 max=-9999 diff=-19998 ofs=0
AD15 min=9999 max=-9999 diff=-19998 ofs=0
matchSignal size=24
subSample=4
capture size=192
IMU error: no calib data
accOfs=0.00,0.00,0.00
accScale=2.00,2.00,2.00
comOfs=0.00,0.00,0.00
comScale=2.00,2.00,2.00
initL3G4200D
gyro read error
gyro read error
gyro read error
loadSaveErrorCounters: read
loadSaveErrorCounters addrstop=422
loadUserSettings
loadSaveUserSettings addrstop=263
loadSaveRobotStats: read
loadSaveRobotStats addrstop=822
START
Ardumower 1.0a6-Azurit
Config: Ardumower
press...
d for menu
v to change console output (sensor counters, values, perimeter etc.)
sen_counters
Error: motor left fault
t 0 l 0 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 0.0 chg 0.0 0.0 imu 0 adc 0 Ardumower
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
t 0 l 0 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 0.0 chg 0.0 0.0 imu 0 adc 0 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
t 1 l 0 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.9 chg 17.6 0.0 imu 0 adc 10 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
t 2 l 25 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.8 chg 17.5 0.0 imu 0 adc 12 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
t 3 l 12 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.6 chg 17.4 0.0 imu 0 adc 12 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
t 4 l 12 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.5 chg 17.3 0.0 imu 0 adc 12 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
t 5 l 12 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.4 chg 17.2 0.0 imu 0 adc 12 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
t 6 l 12 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.3 chg 17.2 0.0 imu 0 adc 15 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
buttonPressed
t 8 l 39 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.2 chg 17.1 0.0 imu 0 adc 9 Ardumower
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
loadSaveRobotStats: write
loadSaveRobotStats addrstop=822
t 0 l 9 v0 OFF spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.2 chg 17.1 0.0 imu 0 adc 1 Ardumower
Error: motor left fault
t 0 l 9 v0 ERR spd 0 0 0 sen 0 0 0 bum 0 0 dro 0 0 son 0 yaw 0 pit 0 rol 0 bat 17.2 chg 17.1 0.0 imu 0 adc 1 Ardumower
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor left fault
Error: motor right fault
Error: motor mow fault
Error: motor

usw.

Ich hoffe das hilft den fehler einzugrenzen.
Ich hatte überlegt ich besorge mir Hall sensoren und baue die Radsensoren neu auf...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9827

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Hallo nochmal hier sind die settings die ich ausgelesen habe.
wheel motors
motorAccel : 1000.00
motorSpeedMaxRpm : 25
motorSpeedMaxPwm : 255
motorPowerMax : 75.00
motorSenseRightScale : 15.30
motorSenseLeftScale : 15.30
motorPowerIgnoreTime : 2000
motorZeroSettleTime : 3000
motorRollTimeMax : 1500
motorRollTimeMin : 750
motorReverseTime : 1200
motorForwTimeMax : 80000
motorBiDirSpeedRatio1 : 0.30
motorBiDirSpeedRatio2 : 0.92
motorLeftPID.Kp : 1.50
motorLeftPID.Ki : 0.29
motorLeftPID.Kd : 0.25
motorRightSwapDir : 0
motorLeftSwapDir : 0
mower motor
motorMowAccel : 2000.00
motorMowSpeedMaxPwm : 255
motorMowPowerMax : 75.00
motorMowModulate : 0
motorMowRPMSet : 3300
motorMowSenseScale : 15.30
motorMowPID.Kp : 0.00
motorMowPID.Ki : 0.01
motorMowPID.Kd : 0.01
motorMowModulate Interrupt
motorMowModulate Interrupt : 0
bumper
bumperUse : 1
drop
dropUse : 0
dropContact : 1
rain
rainUse : 0
sonar
sonarUse : 0
sonarLeftUse : 1
sonarRightUse : 1
sonarCenterUse : 0
sonarTriggerBelow : 1050
perimeter
perimeterUse : 0
perimeterTriggerTimeout : 0
perimeterOutRollTimeMax : 2000
perimeterOutRollTimeMin : 750
perimeterOutRevTime : 2200
perimeterTrackRollTime : 1500
perimeterTrackRevTime : 2200
perimeterPID.Kp : 51.00
perimeterPID.Ki : 12.50
perimeterPID.Kd : 0.80
trackingPerimeterTransitionTimeOut : 2000
trackingErrorTimeOut : 10000
trackingBlockInnerWheelWhilePerimeterStruggling : 1
lawn sensor
lawnSensorUse : 0
IMU (compass/accel/gyro)
imuUse : 0
imuCorrectDir : 0
imuDirPID.Kp : 5.00
imuDirPID.Ki : 1.00
imuDirPID.Kd : 1.00
imuRollPID.Kp : 0.80
imuRollPID.Ki : 21.00
imuRollPID.Kd : 0.00
model R/C
remoteUse : 0
model R/C Interrupt
Pin 10 pinRemoteSpeed : 0
Pin 11 pinRemoteSteer : 0
Pin 12 pinRemoteMow : 0
Pin 52 pinRemoteSwitch : 0
battery
batMonitor : 0
batGoHomeIfBelow : 23.70
batSwitchOffIfBelow : 21.70
batSwitchOffIfIdle : 1
batFactor : 0.50
batChgFactor : 0.50
batFull : 14.40
batChargingCurrentMax : 1.60
batFullCurrent : 0.30
startChargingIfBelow : 27.00
chargingTimeout : 12600000
chgSelection : 2
chgSenseZero : 511.00
chgFactor : 39.00
chgSense : 185.00
chgChange : 0
chgNull : 2
charging station
stationRevTime : 1800
stationRollTime : 1000
stationForwTime : 1500
stationCheckTime : 1700
odometry
odometryUse : 0
twoWayOdometrySensorUse : 0
odometryTicksPerRevolution : 1060
odometryTicksPerCm : 13.49
odometryWheelBaseCm : 36.00
odometryRightSwapDir : 0
odometryLeftSwapDir : 1
Odometry Interrupt
oneway left : 0
Oneway right : 0
twoway left : 0
twoway right : 0
GPS
gpsUse : 0
stuckIfGpsSpeedBelow : 0.20
gpsSpeedIgnoreTime : 5000
other
buttonUse : 1
user-defined switch
userSwitch1 : 0
userSwitch2 : 0
userSwitch3 : 0
timer
timerUse : 0
bluetooth
bluetoothuse : 0
esp8266
esp8266Use : 0
esp8266ConfigString : 123test321
robot stats
statsMowTimeMinutesTrip : -1
statsMowTimeMinutesTotal : 4294967295
statsBatteryChargingCounterTotal : -1
statsBatteryChargingCapacityTrip in mAh : 0.00
statsBatteryChargingCapacityTotal in Ah : 0.00
statsBatteryChargingCapacityAverage in mAh : 0.00
DONE

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9829

  • nero76
  • nero76s Avatar
  • Offline
  • Administrator
  • Administrator
  • cofounder of www.ardumower.de
  • Beiträge: 2307
  • Dank erhalten: 818
Der Ardumower Motortreiber (MC33926) hat Fehler-Ausgänge (Fault) welche Du bei Deinem "falschen" Motortreiber nicht hast.

Error: motor left fault
Error: motor right fault
Error: motor mow fault

Du müsstest wohl die entsprechenden Zeilen wo die Ausgänge eingelesen werden in mower.cpp (checkMotorFault) auskommentieren.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

PCB1.3 - die Plug&Play Robotik-Plattform für Deinen Rasenroboter mit passender Open Source Software
Letzte Änderung: von nero76.

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9847

  • Paddy
  • Paddys Avatar
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 459
  • Dank erhalten: 206
Hallo,

schau mal hier. So habe ich es gelöst.
ardumower.de/index.php/de/forum/eure-ard...2-tc-158n-umbau#9445

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Tianchen TC-158N umgebaut auf Ardumower 1.0a10-dev Azurit
Klarstein Cleantouch Staubsauger umgebaut auf Ardumower 1.0a5 Azurit
Ardumower Arctic Hare

www.weberpatrick.de

Problem mit Inbetriebnahme 3 Jahre 2 Monate her #9856

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
So, nach unserem Einschulungswochenende hatte ich heute wieder Zeit mich um den Mower zu kümmern.
Leider bin ich kein Stück weitergekommen. Ich habe alle Änderungen die Ihr aufgezeigt habt durchgeführt.
Da ich in den Post von mehreren Leuten gelesen habe das das Board doch besser ist,
habe ich mich nun doch dazu durch gerungen, das Board zu bestellen. Bis das da ist, geht es hier nicht weiter.

Vorerst allen vielen Dank

Björn

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Problem mit Inbetriebnahme 3 Jahre 1 Monat her #10026

  • bastelbjoern
  • bastelbjoerns Avatar Autor
  • Offline
  • Benutzer
  • Benutzer
  • Beiträge: 13
  • Dank erhalten: 1
Hallo, ich bin dieses Wochenende mal wieder dazu gekommen etwas zu basteln.
Was soll ich berichten.... er fährt!!! Nach diversen versuchen mit der 05 und der 06 las ich RTC wird ab 04 benötigt.
also habe ich alle änderungen in die 02 Version gepackt. und er läuft!
Also fast, nur das Mähwerk schaltet die kiste nicht ein (MOSFET an PWM2)
Kann man in der Software irgendwo aus dem PWM ein Schaltausgang mit stumpf ein/ aus machen ?
Achso, das bestellte Board wird für V 2 verwende. Im Scharco ist noch immer das kabel wirrwarr..;)

Danke an allen, mit euren Anregungen habt ihr mir sehr weiter geholfen.

Gruß Björn

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
Moderatoren: runtimeterror
Ladezeit der Seite: 0.350 Sekunden