Welcome, Guest
Username: Password: Remember me
25 Feb 2017
Das neue Board ist ab sofort HIER ERHÄLTLICH
Aufbauvideos im WIKI findet Ihr hier.
  • Page:
  • 1
  • 2

TOPIC: Ambrogio L200 Evolution

Ambrogio L200 Evolution 3 months 1 week ago #13529

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Hallo,

ich bin neu im Forum und möchte mein geplantes Projekt vorstellen.

Ich habe günstig einen Ambrogio L200 Evolution bekommen und möchte diesen mit eurer Steuerung betreiben.
Es ist die Ladestation vorhanden aber kein Netzteil.
Könntet Ihr mir helfen und schreiben, was ich vom Ambrogio benutzen kann und was ich dazu kaufen muss.
Im Anhang hänge ich noch Bilder an.

Vielen Dank
Lieben Gruß Rafael

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 3 months 1 week ago #13539

  • gk
  • gk's Avatar
  • Offline
  • User
  • User
  • Posts: 29
  • Thank you received: 16
Hallo

Ich habe ein älteres Modell dieser Serie mit Bleiakku umgebaut, und nur das Chassis und die Motoren verwendet.
Ein Radmotor war aber defekt und ist manchmal einfach stehengeblieben. also habe ich beide Motoren tauschen müssen, die Getriebe aber weiter verwendet.
Beim Mähmotor habe ich auch noch ein Kugellager getauscht.
Das Displayloch habe ich einfach mit einer Folie überklebt, weil ich es nicht verwende.

Du wirst also die komplette Elektronik brauchen inklusive Sender und Ladegerät.
Ich habe damals alles auf Lochrasterplatine mit einem mega2560 und l298 Treiber gebaut, würde dir aber Pcb1.3 mit einem Due empfehlen.
Das Problem ist nur die Platzierung, weil es grösser als das Originalboard ist(laut Wiki 272x115mm), .
Vielleicht findest du ja einen geeigneten Platz
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 3 months 1 week ago #13545

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Hallo,

Vielen Dank für die Antwort.
Hättest du eventuell ein paar Bilder?
Könnte ich die Kontakte vom Regensensor verwenden?
Ich hoffe, dass das PCB 1.3 auf die andere Seite vom jetzigen Bord passt.
DUE anstatt MEGA? Wo sind die Vor- und Nachteile?

Vielen Dank
Gruß Rafael

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 3 months 1 week ago #13547

  • Alex76
  • Alex76's Avatar
  • Offline
  • User
  • User
  • Posts: 72
  • Thank you received: 7
Der Due arbeitet schneller und damit flüssiger..der Mega läuft
zwar auch im Normalbetrieb aber Befehle sind teils stärker verzögert, sodas man sich machmal fragt was er da gerad macht ;)
(Ich bin da auch etwas ungedultg)

Beim Einstellen etc nervt der Mega ein wenig.. ich glaub ab im normalbetrieb würden beide klarkommen.
LG Aleks
(Selbst anfängerstatus)
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 3 months 1 week ago #13549

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Könnte mir einer schreiben, ob ich das alles benötige?
Oder ob es Vorschläge gibt was ich noch dazu nehmen könnte.

- Zubehör Set für das 1.3 Ardumower Mainboard
1x24V PCB Zubehör für das 1.3 Ardumower Mainboard
- Board Auswahl Mega / Due
1xDUE Entwicklungsboard R3 32-Bit ARM Cortex-M3 Arduino Kompatibel
- INA169 Strom Sensor Board
1xINA169 Analog DC Current Sensor Breakout - 60V 2,5A / 5A Marotronics
- MC33926 Dual Motor Treiber
2x Dual MC33926 Motor Driver Carrier
- Wireless Bluetooth Modul HC-05
1xWireless Bluetooth Modul HC-05
- GPS Modul GY-GPS6MV2
1xNEO-6M GPS Modul GY-GPS6MV2 NEO-6M Flight Controller z.b. für Arduino
- Gyro-801
1xGyro-801
- Real Time Clock I2C DS1307
1xReal Time Clock Modul I2C RTC DS1307 z.B. für Arduino
- Regensensor
1xRegensensor Modul YL-38 für Arduino Raspberry PI Regentropfen Sensor Nässesensor
- WIFI Wlan Modul ESP8266 ESP01
1xESP8266 WIFI Wlan Serial Modul ESP01 für Arduino
- DC-DC Wandler
1xDC-DC Spannungsregler LM2596S Step-Down Regler einstellbar
- Schleifenempfänger Kit
2xSchleifenempfänger Kit, perimeter receiver Kit

Kann ich den vorhandenen Regensensor verwenden?
Gibt es eine Möglichkeit die Anfahrschalter weiter zu verwenden? (siehe Anhang)

LG Rafael
Attachments:

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 3 months 1 week ago #13558

  • gk
  • gk's Avatar
  • Offline
  • User
  • User
  • Posts: 29
  • Thank you received: 16
Das Gps Modul hat derzeit noch keine Funktion.
Mit Imu gibts auch immer wieder Probleme, wie ich hier im Forum gelesen habe.
Beides bei mir nicht verbaut. Habe sie aber schon zu Hause. Für die neue sunray Version würde man aber Gy-88 als Imu brauchen.
Wlan braucht man nicht unbedingt( man hat sowieso nur die Möglichkeit eines zu verwenden, entweder Wlan oder Bluetooth) Wlan ist meiner Meinung schwieriger, weil man das Modul flashen muss. Ich habe es nur mit der Esp-Link Software zum laufen bekommen, aber auch nicht so zuverlässig wie mit Bluetooth.
Schleifenempfänger geht nur einer für Azurith, aber gleich 2 besorgen für Sunray.
Ausserdem brauchst du noch den Schleifensender+ Ina169+ Mc33926+ lm2596+ Nano+ Lastwiderstand(Bei mir Uno+ Motorshield+ Ina169+ lm2596), und einen Hauptschalter.

Den Regensensor und die Bumperschalter kann man verwenden(_PULLUP eingestellt auch für den Regensensor, weil ich ihn auf Gnd schalte).
Der Drehzahlsensor vom Mähmotor ist nicht aktiv
im Anhang noch Fotos von meinem Eigenbau
Attachments:
The following user(s) said Thank You: elektronikjogi, rafael228

Please Log in or Create an account to join the conversation.

Last Edit: by gk. Reason: Hauptschalter und Drehzahlsensor hinzugefügt

Ambrogio L200 Evolution 2 months 4 weeks ago #13641

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Hallo,

ich habe mir das PCB 1.3 besorgt und nun wollte ich,
nachdem ich mir ein Ladegerät gekauft habe, die erste Inbetriebnahme starten.
Leider musste ich feststellen, dass die Batterie sich nicht mehr laden lässt.
Was würden Ihr mir empfehlen?
Gibt es eine Möglichkeit die Batterie zum Leben zu erwecken?

LG Rafael

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 4 weeks ago #13642

  • Kurzschuss
  • Kurzschuss's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 631
  • Thank you received: 195
was für ein Spannung hat denn noch die Batterie
Evl ein Lipo Lader vorhanden oder ein Regelbares Netzteil mit Strombegrenzung und eine Diode?

Gruß
Uwe

Please Log in or Create an account to join the conversation.

aktuelle Dokumentation / latest documentation
-> github.com/Ardumower/ardumower/tree/master/Dokumentation

Englische Sprache (Übersetzung) mit Hilfe von Google Translate
English language (translation) with the help of Google Translate

Ambrogio L200 Evolution 2 months 4 weeks ago #13644

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Batterie hat keine Spannung mehr.
Multimeter zeigt nur mV an.
Denke die Batterie wird hinüber sein.
Regelbares Netzteil habe ich leider nicht.

Gruß
Rafael

Please Log in or Create an account to join the conversation.

Last Edit: by rafael228.

Ambrogio L200 Evolution 2 months 4 weeks ago #13645

  • Kurzschuss
  • Kurzschuss's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 631
  • Thank you received: 195
Dann schätze ich mal das der Akku hin ist.
Es gibt zwar Ladegeräte die zum Teil tief entladene Akkus wiederbeleben können, das mach in meinen Augen nicht viel Sinn.
Da nicht mal eine Restspannung messbar ist glaube ich das du da schlechte Aussichten hast. Die meisten lipo Akkus stecken eine Unterspannung nicht unbedingt gut weg. Es könnte auch durchaus sein das eine Zelle ganz kaputt ist( weil es wird keine Resrspannung gemessen). Das lässt sich dann auch nicht unbedingt feststellen. Ein entsprechendes Ladegerät zu kaufen nur für den wagen Versuch finde ich ist auch Geld rausgeworfen außer es wird auch noch anders eingesetzt und gebraucht wie zum Beispiel im Modellbau. Weil wenn es nicht funktionieren sollte brauchst du dann immer noch ein Akku.
Ich würde eher dazu raten mir gleich einen neuen Akku zuzulegen.

Wir verwenden alle diesen Akku und haben sehr gute Erfahrungen damit gemacht. Mit der Spannung müsste er auch bei dir passen. Zu den Abmessungen kann ich leider nichts sagen.
www.marotronics.de/Ardumower-Power-Pack-...i-Mn-Akku-13790-Euro

www.asn-shop.de/Ardumower-Power-Pack-252V-5Ah
Wenn er im Shop nicht als verführbar angezeigt wird einfach dort anrufen. Dann wir der Akku entsprechend zusammengestellt.

Gruß
Uwe
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

aktuelle Dokumentation / latest documentation
-> github.com/Ardumower/ardumower/tree/master/Dokumentation

Englische Sprache (Übersetzung) mit Hilfe von Google Translate
English language (translation) with the help of Google Translate

Ambrogio L200 Evolution 2 months 4 weeks ago #13646

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Eine Frage hätte ich noch.

Macht es Sinn in Zukunft 2 dieser verlinkten Batterien zu kaufen?
Mache mir Gedanken weil ich ca. 1500m2 Rasenfläche zu mähen habe.

Gruß
Rafael

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 4 weeks ago #13647

  • Kurzschuss
  • Kurzschuss's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 631
  • Thank you received: 195
Nach kaufen kann man immer noch. Ich würde mir erst mal ein Akku kaufen um zu sehen wie man damit zurecht kommt. Die Fläche die er bearbeiten tut kann man ja auch damit beeinflussen wie oft ich ihn mähen lasse.
Man kann ja sagen das er alle 2 Tage nur einmal am Tag mäht oder am Tag mehrmals . Man kann ihn auch jeden Tag mähen lassen . Mit diesen Möglichkeiten kann man dann auch schon mal größere Flächen bearbeiten.
Da muss man dann etwas probieren bis das Schnittbild passt.
Einfach mal eine Woche oder etwas länger nicht mähen damit das Gras sichtbar länger steht. Dann einfach mal mit vollen Akku testen was er mit einer Ladung schafft. Das sieht man dann auf den Gras ganz gut was er an Fläche geschafft hat. . Damit lässt sich dann ganz gut beurteilen wie oft er mähen muss. 1-3 mal pro Tag oder jeden Tag oder nur alle 2-3 Tage.

Gruß
Uwe
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

aktuelle Dokumentation / latest documentation
-> github.com/Ardumower/ardumower/tree/master/Dokumentation

Englische Sprache (Übersetzung) mit Hilfe von Google Translate
English language (translation) with the help of Google Translate

Ambrogio L200 Evolution 2 months 1 week ago #13737

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Hallo,

ich habe es nun geschafft das Main zusammen zu löten.
Bei der ersten Inbetriebnahme, wie sie im Video erklärt wird, funktioniert auch alles bis ich den DUE anschließe.
Es leuchten alle LEDs wie sie sollen aber der Speaker piept ununterbrochen.
Das Bargraph leuchtet auch nicht wie im Video.
Im Anhang lege ich ein Bild vom Zustand. Die Lampen leuchten alle durchgängig, keine blinkt.

Gruß Rafael
Attachments:

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 1 week ago #13742

  • gk
  • gk's Avatar
  • Offline
  • User
  • User
  • Posts: 29
  • Thank you received: 16
Hallo

Ich habe kein Pcb 1.3, aber weil keine Led blinkt:
Spannungen stimmen alle? Ist Der Due richtig gesteckt?
Ist auf dem Due schon eine Software geflasht worden? Im Neuzustand müsste eine Led blinken.

Wenn sonst alles passt würde ich die Developer Version flashen, und in der Seriellen Konsole Factory-reset und Adc-Kalibrierung durchführen.
Dann schauen ob Fehler auftreten.
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 1 week ago #13744

  • Alex76
  • Alex76's Avatar
  • Offline
  • User
  • User
  • Posts: 72
  • Thank you received: 7
Das mit dem Dauerpiepen habe ich auch gehabt, da lag der Fehler darin das der Due scheinbar nicht richtig geflasht war.
Obwohl alles korrekt durchgeführt war, hatte ich ein Dauerpiepen. Nachdem ich den Due neu geflasht hatte lief er wieder normal.
LG,
Alex
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 1 week ago #13756

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Hallo,

vielen Dank für die Antworten.
Ich musste beim DUE den Reset Knopf drücken und schon hat er geblinkt.

Den Motortest habe ich auch erfolgreich durchgeführt.
Ich frage mich nun wo und wie ich die Odometrie anschließe.
Von den Motoren kommen ja noch 3 Kabel (rot, schwarz und gelb).
Müssen diese irgendwo angeklemmt werden?

Gruß Rafael

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 1 week ago #13763

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Die Adern habe ich an den ODO left und right angeklemmt.
Nun sind die Motoren aber sehr träge und reagieren nicht mehr so schnell auf Befehle
beim linken Antriebsmotor werden auch keine Istwerte angezeigt.

Gruß Rafael

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 1 week ago #13764

  • gk
  • gk's Avatar
  • Offline
  • User
  • User
  • Posts: 29
  • Thank you received: 16
Hallo
Wenn die Konfig vom Ardumower geflasht wurde, dann liegt daran, glaube ich.
In der mower.cpp habe ich natürlich die Werte für meinen Roboter passend eingestellt.

z.B.: #if defined (ROBOT_ARDUMOWER)
odometryTicksPerRevolution = 360; // encoder ticks per one full resolution (without any divider)
wheelDiameter = 210; // wheel diameter (mm)
odometryWheelBaseCm = 38;

(Ich habe aber andere Motoren drin! )
Beim neuflashen mit den anderen Werten, soll man immer in der App die Werkseinstellungen laden und dann Aus und einschalten.
Die Odometrieticks überprüfen: mit Usb verbinden -> in der Konsole gibt es Odometrietest, auch nur für eine Umdrehung.

Mit einem Klebeband markieren und schauen ob die Räder sich eine Umdrehung drehen. Wenn es nicht passt -> Die Ticks per Revolution ändern, und wieder flashen.
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

Ambrogio L200 Evolution 2 months 1 week ago #13773

  • rafael228
  • rafael228's Avatar Topic Author
  • Offline
  • User
  • User
  • Posts: 13
  • Thank you received: 0
Hallo,

ich habe es nun soweit, dass der rechte Motor die Umdrehung hin bekommt.
Der linke allerdings schafft es nicht.
Die Motoren laufen nicht gleich schnell.
Woran kann das liegen?
Ich ändere in der mower.cpp die odometryTicksPerRevolution auf 360, wenn ich dann die App öffne, ist bei Ticks per one full revolution 180 eingestellt?
Müssten da nicht auch die 360 stehen?

Gruß

Please Log in or Create an account to join the conversation.

Last Edit: by rafael228.

Ambrogio L200 Evolution 2 months 1 week ago #13778

  • gk
  • gk's Avatar
  • Offline
  • User
  • User
  • Posts: 29
  • Thank you received: 16
Hallo

Das die Motoren nicht gleich schnell laufen gibt es auch bei den Motoren aus dem shop.

Die Ticks per Revolution werden /2 dividiert wenn man pcb1.3 hat, die könnte man sonst einfach verdoppeln.
Wie gesagt wichtig ist, das die Umdrehung stimmt.
Wenn der eine Motor jetzt eine Umdrehung dreht, zählt der Zähler jetzt 180 Ticks oder 360? Wieviel weniger hat der andere? Pro ganze Umdrehung sollten es genausoviel sein.
Jemand im Forum hat geschrieben das es mit zu wenig Ticks nicht optimal läuft. Vielleicht sollte man dann wieder rising und falling bei deinem Mäher auswerten.

Ganz gerade fährt meiner auch nicht, aber ich wohne auf einem Hang. Wenn er schräg fährt macht er immer eine leichte Biegung abwärts
The following user(s) said Thank You: rafael228

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Moderators: Hobby-Bastler
Time to create page: 0.366 seconds